El otro dia Instalando un nuevo ambiente de pruebas, me salio el siguiente error cuando corri runInstaller, libXext.so.6: cannot open shared object file: No such file or directory en RHEL 6, asi que en luger de poder continuar con mi instalacion de ambiente de prueba, me puse a buscar por que me habia salido este error.

[oracle@oracleenespanol database]$ ./runInstaller 
Starting Oracle Universal Installer...

Checking Temp space: must be greater than 120 MB. Actual 41652 MB Passed
Checking swap space: must be greater than 150 MB. Actual 3967 MB Passed
Checking monitor: must be configured to display at least 256 colors. Actual 16777216 Passed
Preparing to launch Oracle Universal Installer from /tmp/OraInstall2013-12-11_10-58-10PM. Please wait ...[oracle@oracleenespanol database]$ Exception in thread "main" java.lang.UnsatisfiedLinkError: /tmp/OraInstall2013-12-11_10-58-10PM/jdk/jre/lib/i386/xawt/libmawt.so: libXext.so.6: cannot open shared object file: No such file or directory
at java.lang.ClassLoader$NativeLibrary.load(Native Method)
at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1753)
at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1649)
at java.lang.Runtime.load0(Runtime.java:769)
at java.lang.System.load(System.java:968)
at java.lang.ClassLoader$NativeLibrary.load(Native Method)
at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1753)
at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1670)
at java.lang.Runtime.loadLibrary0(Runtime.java:822)
at java.lang.System.loadLibrary(System.java:993)
at sun.security.action.LoadLibraryAction.run(LoadLibraryAction.java:50)
at java.security.AccessController.doPrivileged(Native Method)
at java.awt.Toolkit.loadLibraries(Toolkit.java:1509)
at java.awt.Toolkit.<clinit>(Toolkit.java:1530)
at com.jgoodies.looks.LookUtils.isLowResolution(LookUtils.java:484)
at com.jgoodies.looks.LookUtils.<clinit>(LookUtils.java:249)
at com.jgoodies.looks.plastic.PlasticLookAndFeel.<clinit>(PlasticLookAndFeel.java:135)
at java.lang.Class.forName0(Native Method)
at java.lang.Class.forName(Class.java:242)
at javax.swing.SwingUtilities.loadSystemClass(SwingUtilities.java:1779)
at javax.swing.UIManager.setLookAndFeel(UIManager.java:453)
at oracle.install.commons.util.Application.startup(Application.java:780)
at oracle.install.commons.flow.FlowApplication.startup(FlowApplication.java:165)
at oracle.install.commons.flow.FlowApplication.startup(FlowApplication.java:182)
at oracle.install.commons.base.driver.common.Installer.startup(Installer.java:348)
at oracle.install.ivw.db.driver.DBInstaller.startup(DBInstaller.java:124)
at oracle.install.ivw.db.driver.DBInstaller.main(DBInstaller.java:155)

Despues de buscar un poco en internet, me di cuenta me faltaban paquetes relacionados con X11, que basicamente son paquetes graficos, el paquete libXp.so.6 en especial era el que me faltaba, asi que me di a la tarea de instalarlos con el usuario root

[root@oracleenespanol ~]# yum provides libXp.so.6
Loaded plugins: refresh-packagekit, security
libXp-1.0.0-15.1.el6.i686 : X.Org X11 libXp runtime library
Repo : public_ol6_latest
Matched from:
Other : libXp.so.6



[root@oracleenespanol ~]# yum install libXp.so.6
Loaded plugins: refresh-packagekit, security
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package libXp.i686 0:1.0.0-15.1.el6 will be installed
--> Processing Dependency: libX11.so.6 for package: libXp-1.0.0-15.1.el6.i686
--> Processing Dependency: libXau.so.6 for package: libXp-1.0.0-15.1.el6.i686
--> Processing Dependency: libXext.so.6 for package: libXp-1.0.0-15.1.el6.i686
--> Running transaction check
---> Package libX11.i686 0:1.5.0-4.el6 will be installed
--> Processing Dependency: libxcb.so.1 for package: libX11-1.5.0-4.el6.i686
---> Package libXau.i686 0:1.0.6-4.el6 will be installed
---> Package libXext.i686 0:1.3.1-2.el6 will be installed
--> Running transaction check
---> Package libxcb.i686 0:1.8.1-1.el6 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

======================================================================================================================================================================================
Package Arch Version Repository Size
======================================================================================================================================================================================
Installing:
libXp i686 1.0.0-15.1.el6 public_ol6_latest 22 k
Installing for dependencies:
libX11 i686 1.5.0-4.el6 public_ol6_latest 590 k
libXau i686 1.0.6-4.el6 public_ol6_latest 24 k
libXext i686 1.3.1-2.el6 public_ol6_latest 33 k
libxcb i686 1.8.1-1.el6 public_ol6_latest 114 k

Transaction Summary
======================================================================================================================================================================================
Install 5 Package(s)

Total download size: 782 k
Installed size: 1.9 M
Is this ok [y/N]: y
Downloading Packages:
(1/5): libX11-1.5.0-4.el6.i686.rpm | 590 kB 00:00
(2/5): libXau-1.0.6-4.el6.i686.rpm | 24 kB 00:00
(3/5): libXext-1.3.1-2.el6.i686.rpm | 33 kB 00:00
(4/5): libXp-1.0.0-15.1.el6.i686.rpm | 22 kB 00:00
(5/5): libxcb-1.8.1-1.el6.i686.rpm | 114 kB 00:00
--------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Total 342 kB/s | 782 kB 00:02
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
Installing : libXau-1.0.6-4.el6.i686 1/5
Installing : libxcb-1.8.1-1.el6.i686 2/5
Installing : libX11-1.5.0-4.el6.i686 3/5
Installing : libXext-1.3.1-2.el6.i686 4/5
Installing : libXp-1.0.0-15.1.el6.i686 5/5
Verifying : libxcb-1.8.1-1.el6.i686 1/5
Verifying : libX11-1.5.0-4.el6.i686 2/5
Verifying : libXext-1.3.1-2.el6.i686 3/5
Verifying : libXau-1.0.6-4.el6.i686 4/5
Verifying : libXp-1.0.0-15.1.el6.i686 5/5

Installed:
libXp.i686 0:1.0.0-15.1.el6

Dependency Installed:
libX11.i686 0:1.5.0-4.el6 libXau.i686 0:1.0.6-4.el6 libXext.i686 0:1.3.1-2.el6 libxcb.i686 0:1.8.1-1.el6

Complete!

Una vez que instale estos paquetes , todo quedo resuelto, continue instalando mis nuevos ambientes de prueba 馃檪